1. ¡OFERTA! con cupón "DIRVPS": hosting por $0,01 y también VPS Linux y Windows por $0,01 el primer mes por Interserver ← publi
    Descartar aviso

Integrar Let's Encrypt

Tema en 'Manejando una empresa de hosting' iniciado por David12, 20 Oct 2016.

  1. David12

    David12 Nuevo usuario

    Hola:

    Necesito integrar Let's Encrypt al cPanel de los clientes, de manera que esté disponible para todos los dominios.

    Lo he instalado desde WHM y lo he habilitado (guía: https://documentation.cpanel.net/display/CKB/The+Let's+Encrypt+Plugin ). Sin embargo no aparece en el cpanel de los clientes.

    He encontrado una guía para en la que aparece la opción en el cPanel: http://www.wpbeginner.com/wp-tutorials/how-to-add-free-ssl-in-wordpress-with-lets-encrypt/

    Foto: http://cdn2.wpbeginner.com/wp-content/uploads/2016/02/cpanelletsencrypt.jpg

    Pero en mi caso no sé cómo agregarlo, ¿me podrían indicar?.

    Gracias, un saludo.
     
  2.  
  3. justice13

    justice13 Usuario activo

    Desconozco si quizá en el Feature manager de los planes debas habilitar la opción. Desde ahí se suelen habilitar opciones para que aparezcan o no.
     
  4. David12

    David12 Nuevo usuario

    Si, pero ya la tengo habilitada. Aún así no aparece en el cPanel del cliente la opción que he indicado en la foto de arriba.

    ¿Alguien tiene alguna idea?. Gracias, un saludo.
     
  5. marin

    marin Usuario activo

    El Let's Encrypt nativo de WHM/cPanel (últimas versiones, antes no existia de modo nativo) no tiene configuración posible en cPanel.

    El producto se configura desde WHM, desde Auto-SSL, tienes que activarlo y configurar Let's Encrypt como Auto-SSL. Luego en las caracteristicas de los planes (las opciones que aparecen en cPanel) podrás deciri que planes tienen acceso a esta función y cuales no con la casilla "Auto SSL".

    El funcionamiento es muy simple y tus usuarios no tienen que hacer nada, aquellas cuentas que tengan derecho a utilizar este certificado SSL el sistema todos los días ejecutará un cron y diariamente revisará los certificados activos y a quien no tenga certificado automáticamente se le creará uno. Ojo, solo se le creará si el dominio está apuntando a tu servidor.

    También renovará los certificados automáticamente y en el caso de que tenga otro certificado SSL cuando este caduque lo cambiará por uno de los suyos.

    Pero el proceso es totalmente automático y libre para el usuario. Tus usuarios no podrán instalarlo, lo tendrán instalado "de fábrica".

    También puedes forzar el "cron" desde el Auto-SSL de WHM tanto para todas las cuentas como para una sola.
     
  6. David12

    David12 Nuevo usuario

    Buenas:

    Gracias por responder. Pero si todos los dominios tienen SSL no se por qué al poner "https://www.midominio.com" me dice que la conexión no es segura en el navegador (arriba a la izquierda, donde el candado).

    En WHM -> Manage AutoSSL -> Administrar usuarios; todos lo tienen como "Enable AutoSSL".

    Del mismo modo, en Paquetes -> Administrador de funciones (Feature manager) -> default (es el que tiene los paquetes); está habilitado AutoSSL.

    ¿A parte de eso debo hacer algo más?, no me explico que no esté para todos los dominios automáticamente entonces.

    Otra duda: si el usuario no quiere usarlo, ¿tiene forma de deshabilitarlo?, ¿o vale simplemente con que no use la URL con https y listo?.

    Gracias por la ayuda. Un cordial saludo.
     
  7. David12

    David12 Nuevo usuario

    Buenas:

    Tengo un nuevo dato: ya tengo claro que todos los dominios tienes SSL, ¿por qué?, porque cuando quiero instalar otro SSL a un dominio en el cPanel, éste me dice que ya hay un SSL Let's Encrypt.

    Sin embargo sigo teniendo la duda, si tiene un SSL porqué al poner en el navegador "https://www.mi-dominio.com" me dice en el candado "La conexión no es segura".

    Gracias. Un cordial saludo.
     
  8. marin

    marin Usuario activo

    Si el certificado está instalado, ¿has mirado que no sea un tema de caché del navegador?

    ¿Cuando miras el certificado de esa "conexión no segura", ¿qué certificado te aparece?
     
  9. David12

    David12 Nuevo usuario

    Parece cosa del Wordpress:

    1. He borrado la caché del navegador
    2. No tengo ningún plugin ni comandos httaccess para cacheo en la web (así que también está limpio).

    Cuando entro al panel de administración ¡si funciona el SSL! (pone Let's Encrypt).

    Sin embargo en el front office no, cuando he revisado el código me he dado cuenta de que las imágenes se cargan desde http y no https, ¿podría ser esto?.

    ¿Cómo lo soluciono?, es decir, en el panel de administración funciona correctamente el SSL pero en el front offce no.

    Gracias. Un cordial saludo.
     
  10. David12

    David12 Nuevo usuario

    Añado algo más a mi mensaje anterior (no me deja editarlo):

    Desde el panel de WordPress ya cambié http://midominio.com por https://midominio.com en el apartado "Enlaces permanentes". Pero solo aparece el candado verde en el panel de administración, no en la página principal (front office).

    Un saludo.
     
  11. justice13

    justice13 Usuario activo

    Prueba a visitar el front desde el modo incógnito que lo hace sin cookies antiguas ni caché, a ver si te funciona o no. Si te funciona, es tu navegador. Si sigue sin ir, te falta algo a cosa más por ahí.
     
  12. David12

    David12 Nuevo usuario

    Tampoco funciona, qué raro.

    Tengo un nuevo dato: he probado con un par de dominios que no tienen WordPress (sino contenido HTML puro) y si funciona, está claro que es por el Wordpress.

    He mirado algunas guías y lo tengo todo correcto, sigo indagando pero si alguien tiene idea de las configuraciones que hubiera que hacer WP para agregar SSL se lo agradecería.

    Gracias por las respuestas. Un saludo.
     
  13. justice13

    justice13 Usuario activo

    Pásame por privado un pantalla o del WP en el back de la configuración (Ajustes).

    Saludos,
     
  14. marin

    marin Usuario activo

    Haz un buscar y reemplazar en la BDD y reemplaza todas las rutas de de http a https (las de tu dominio solo, claro), también puedes reemplazarlo por :// que así variará según sea o no https.

    Por otro lado también tendrás que mirar todas las rutas hacia archivos que estén fuera de tu dominio (imagenes externas, estilos, fuentes, etc.) e intentar ver si hay alguna alternativa "segura" de estas rutas.
     


Alojamiento web, Hosting Reseller, Servidores Dedicados - All in Hosting


      
      
      
      
Sitios amigos: GuiaHosting · Unidominios · Interalta ·