1. [+ Tu HOSTING con dominio GRATIS +] Haz clic aquí para contratarlo desde 3,95€ al mes. ¡Soporte WordPress! ← publi
    Descartar aviso
Descartar aviso
Al usar este sitio web, aceptas que nosotros y nuestros socios podamos establecer cookies para fines tales como personalizar el contenido y la publicidad. Más información.

problema 500 internal error cpanel

Tema en 'Asuntos Técnicos' iniciado por jrlocutor, 9 Ene 2015.

  1. jrlocutor

    jrlocutor Usuario activo

    me urge solucionar este problema alguien que me pueda ayudar por favor, no quiero reiniciar el servidor porque no se si eso logre soluciopnarlo

    Internal Server Error
    500

    failed to open session lockfile: FILE=/var/cpanel/sessions/raw/:YDWq81IIMUHaKJkAP49NeYV6USGDly3h_qOMIRUIjK_410C2K0qjEWnJxKhODm7Q.lock, No such file or directory at /usr/local/cpanel/Cpanel/Session.pm line 261.
     
  2.  
  3. mlumbreras

    mlumbreras Usuario activo

    Podría ser un problema de espacio o de inodes:

    # df -h (para ver si tienes ocupado el 100% del espacio, y deberás aumentar espacio o vaciar)

    # df -i (para ver si tienes los inodes al 100%, y deberás aumentar inodes o eliminar archivos)
     
  4. jrlocutor

    jrlocutor Usuario activo

  5. mlumbreras

    mlumbreras Usuario activo

    Como ves con el comando "df -i", según la captura tienes el número de inodes al 100%. Si el servidor es un VPS, habla con el proveedor para que te aumente el número de inodes. Si es un dedicado, puedes intentar eliminar archivos que no necesites, y si eso no es suficiente, sino tendrás que volver a crear el sistema de archivos (recomedable tener conocimientos para no perder datos).
     
  6. jrlocutor

    jrlocutor Usuario activo

    gracias por la respuesta amigo, es un servidor dedicado, en ese caso como puedo aliminar archivos de ese lugar? que tipos de archivos se almacenan alli para asi no cometer error y eliminar algo que sea necesario?
     
  7. mlumbreras

    mlumbreras Usuario activo

    Ese lugar, es la partición "/", que viendo tus particiones en la captura, la única que está fuera es la partición /home. Revisa los archivos en la partición temporal "/tmp" por si tienes muchos. En general, revisa todos los directorios excepto el directorio /home y elimina cualquier archivo que no sea necesario (si no conoces qué hace un archivo en concreto, buscar su nombre en google, te ayudará).

    Suerte!
     
  8. jrlocutor

    jrlocutor Usuario activo

    pero como puedo aliminar el espacio en concreto de esa particion que esta llena?
     
  9. mlumbreras

    mlumbreras Usuario activo

    El problema no es de espacio, el espacio lo tienes correcto. El problema lo tienes con los inodes, para que lo entiendas, el problema es que tienes un número de archivos elevado, aunque el archivo pese sólo 1KB. Tienes demasiados archivos, tienes que eliminar archivos tal como te comenté antes. No importa que pesen poco, tienes que reducir el número de archivos.
     
  10. jrlocutor

    jrlocutor Usuario activo

    el problema al parecer es que tengo demasiadas colas de email en el servidor que ocasionan esta saturacion pero no se como eliminar ello o como hacer para solucionar tal asunto y asi liberar todo ese espacio
     
  11. jrlocutor

    jrlocutor Usuario activo

    elimino varios archivos y se libera poco espacio y luego vuelve dicho espacio a quedar en cero no entiendo vrealmente que deba estar pasando
     
  12. Sphyr0

    Sphyr0 Usuario activo

    Si usas exim, puedes borrar los correos en cola con

    exim -bp | exiqgrep -i | xargs exim -Mrm

    ;)
     
  13. ideasmultiples

    ideasmultiples Usuario activo

    jrlocutor, lumbreras ofrece un excelente servicio profesional, contrátala....
    :cool:
     
    A mlumbreras le gusta esto.
  14. jrlocutor

    jrlocutor Usuario activo

    el problema se me resolvio con la eliminación de los correos en cola, tenia una cantidad enorme de correos en cola y no entiendo el porqué no sé si estoy siendo victima de spam
     
  15. Hola,

    Eso es por que no tienes configurado en el WHM un envio máximo de correos por hora. Deberías mirar cuantos inodos tienes disponible en la partición raíz "/" y comprobar que sean los correctos para esa partición.

    En el Tweak Settings - Mail de cpanel busca: Max hourly emails per domain. Desde SMTP con cualquier formulario en php pueden enviarte e-mails y si no tienes configurada dicha opción se te llena la cola y se te comen los inodos. O algún cliente con PHPList por ejemplo.

    Salu2,
     
  16. Skamasle

    Skamasle Usuario activo

    Y según tu que pasará si configura un envío máximo de emails por hora ?

    Lo mismo :pensativo:

    Si configuras esa opción se quedaran los emails en cola igualmente, es justamente para eso, para que no manden todos los emails de "golpe" si configuras 200 por hora, se mandaran 200 por hora y el resto quedará en cola esperando para que se envien a la hora siguiente.
     
    A justice13 le gusta esto.


Alojamiento web, Hosting Reseller, Servidores Dedicados - All in Hosting


Blog · Sitios amigos: GuiaHosting · Unidominios · Interalta · Sobre Devandhost · Efranet