1. ¡OFERTA! con cupón "DIRVPS": hosting por $0,01 y también VPS Linux y Windows por $0,01 el primer mes por Interserver ← publi
    Descartar aviso
Descartar aviso
Al usar este sitio web, aceptas que nosotros y nuestros socios podamos establecer cookies para fines tales como personalizar el contenido y la publicidad. Más información.

problema al instalar eaccelerator

Tema en 'Web Hosting' iniciado por jose2007, 10 Nov 2007.

  1. jose2007

    jose2007 Usuario activo

    Hola, escribo aquí porque estado buscando información y encontré un manual de como instalar el Eaccelerator en mi dedicado y cuando intento instalarlo me sale un error en el siguiente paso y no se como puedo solucionarlo

    los pasos que pone el manual son los siguientes:

    el paso que me da el error es el siguinete:

    el error es este



    el systema operativo es Centos 4 con directadmin de panel

    agradeceria si alquien mi ayudara con este problema...


    Muchas gracias
     
  2.  
  3. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Creo que al tutorial que te refieres, es al que postee hace poco, este.
    Me parece que te falto correr el comando

    CODE, HTML o PHP Insertado:
    export PHP_PREFIX="/usr"
    Prueba hacer eso primero, y si eso no funciona, prueba esto:

    Tipea estos dos comandos, y pega su salida por favor:

    CODE, HTML o PHP Insertado:
    which phpize
    whereis phpize
    Esos dos comandos te deberían decir la ubicación de phpize.
    Si el primero te devuelve una ruta del archivo, usa esa ruta en vez de:

    CODE, HTML o PHP Insertado:
    $PHP_PREFIX/bin/phpize
    También deberás cambiar $PHP_PREFIX/bin/php-config por /usr/sbin/php-config en la línea:

    CODE, HTML o PHP Insertado:
    ./configure --enable-eaccelerator=shared --with-php-config=$PHP_PREFIX/bin/php-config
    Saludos,
     
  4. jose2007

    jose2007 Usuario activo

    Hola muchas gracias por por responder he echo lo que me as dicho ejecutado los dos comando y te pego los resultado

    Ahora que ago lo que me as puesto abajo?

    EDITO: si el manual es este...

    Muchas gracias
     
  5. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Vamos a hacerlo más fácil, ahora prueba volver hasta la parte donde exportas el directorio, corre:

    CODE, HTML o PHP Insertado:
    export PHP_PREFIX="/usr/local"
    Y sigue como lo marca el tutorial, debería funcionar sin realizar ningún otro cambio.

    Saludos,
     
  6. jose2007

    jose2007 Usuario activo

    gracias por tu respuesta, he echo lo que me as dicho pero en el ultimo paso este me da este error:

    comando:

    error:

     
  7. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Prueba con:
    CODE, HTML o PHP Insertado:
    cp /usr/local/lib/php/extensions/no-debug-non-zts-20020429/eaccelerator.so /usr/local/lib/php/extensions/ -fv --reply=yes
    Luego edita el archivo/usr/local/lib/php.ini y asegurate que extension_dir sea igual a esta forma:

    CODE, HTML o PHP Insertado:
    extension_dir = "/usr/local/lib/php/extensions/"
    Saludos,
     
  8. jose2007

    jose2007 Usuario activo

    Hola el comando que me pasastes me dava el mismo erro y usado este luego he seguido los otros pasos...

    luego he seguido los otros pasos pero me parece que no me a funcionado, te paso lo que puse en el php.ini:

    lo puse abajo del todo del php.ini


     
  9. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Bien, al final de php.ini, debe quedar asi:

    CODE, HTML o PHP Insertado:
    ;;eAccelerator
    extension_dir = "eaccelerator.so"
    eaccelerator.shm_size="16"
    eaccelerator.cache_dir="/php-cache"
    eaccelerator.enable="1"
    eaccelerator.optimizer="1"
    eaccelerator.check_mtime="1"
    eaccelerator.debug="0"
    eaccelerator.filter=""
    eaccelerator.shm_max="0"
    eaccelerator.shm_ttl="0"
    eaccelerator.shm_prune_period="0"
    eaccelerator.shm_only="0"
    eaccelerator.compress="0"
    Borra toda esa configuración que tienes tu , y pega tal cual está esta nueva que te he dado.

    Luego de eso, presiona CTRL + W, y busca la palabra "extension_dir", una vez la encuentres, asegúrate de que quede así:

    CODE, HTML o PHP Insertado:
    extension_dir = "/usr/local/lib/php/extensions/"
    Saludos,
     
  10. jose2007

    jose2007 Usuario activo

    hola compañero lo he puesto tal como dices pero veo que no me funciona no entiendo porque

     
  11. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Hola José,

    Pues no, hay diferencias, no lo has puesto como yo te he dicho, abajo de todo, la config de eaccelerator debe ser así:

    CODE, HTML o PHP Insertado:
    ;;eAccelerator
    extension_dir = "eaccelerator.so"
    eaccelerator.shm_size="16"
    eaccelerator.cache_dir="/php-cache"
    eaccelerator.enable="1"
    eaccelerator.optimizer="1"
    eaccelerator.check_mtime="1"
    eaccelerator.debug="0"
    eaccelerator.filter=""
    eaccelerator.shm_max="0"
    eaccelerator.shm_ttl="0"
    eaccelerator.shm_prune_period="0"
    eaccelerator.shm_only="0"
    eaccelerator.compress="0"
    Tu tienes una línea de más:

    CODE, HTML o PHP Insertado:
    ;;eAccelerator
    [B][I][U]extension_dir = "/usr/local/lib/php/extensions/"[/U][/I][/B] --- esta!
    eaccelerator.shm_size="16"
    Borra la línea que te señalé pues esa línea no se debe agregar al php.ini, ya viene por defecto en ese archivo. Una vez terminado lo anterior, guarda el archivo.

    Para evitar más confusiones, edítalo aparte nuevamente:

    CODE, HTML o PHP Insertado:
    nano /usr/local/lib/php.ini
    Eso te abrirá un editor de textos, luego presiona "CTRL + W", abajo a la izquierda verás que dice "Buscar", pues ahi escribes "extension_dir" y presionas enter, eso te llevará hasta donde esta la variable extension_dir, ahí solo modifícala y déjala tal cual te comenté antes:

    CODE, HTML o PHP Insertado:
    extension_dir = "/usr/local/lib/php/extensions/"
    Guarda el archivo, reinicia apache y estaría listo.

    Saludos,
     
  12. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Bueno, he obviado algo importante, recién me acabo de dar cuenta :-(

    CODE, HTML o PHP Insertado:
    el systema operativo es Centos 4 con directadmin de panel
    Estás usando directadmin, y este tutorial no está orientado a directadmin, sino a cPanel :rolleyes: como bien se aclara en http://comunidadhosting.com/showthread.php?p=29771 .

    Igualmente creo que debería funcionar, si bien no uso directadmin, creo que también se encuentra en el mismo lugar el php.ini.

    Saludos,
     
  13. jose2007

    jose2007 Usuario activo

    Hola compañero ahora mismo lo tengo de este modo i no me funciona no se donde puedo equivocarme:


    abajo del todo lo siguiente:

    Edito: si uso directadmin y la ruta del php.ini es la siguiente

     
  14. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Es bastante raro, tendria que estar funcionando. Igualmente, con todas las idas y venidas que tuviste esta tarde, te sugiero que lo hagas desde cero, borra la config de eaccelerator desde el php.ini e intenta hacerlo todo correctamente otra vez.

    Saludos,

    PD: nunca pude probar eaccelerator en DirectAdmin, deberia funcionar, pero no te lo puedo asegurar al 100%.
     
  15. jose2007

    jose2007 Usuario activo

    ok mañana lo pruevo de nuevo muchas gracias por tu tiempo...

    Saludos
     
  16. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    Bueno, José me ha confirmado que ha funcionado mi tutorial también en DirectAdmin, por si alguien más quiere intentarlo :)

    Saludos,
     
  17. frankxd

    frankxd Usuario activo

    Hola yo tengo un CentOs con Plesk 8.3.0, como podria instalar el Eaccelerator? a la hora de correr el phpize, me tira que no existe. lo busco con el comando which phpize, y me tira: /usr/bin/which: no phpize in (//sbin://bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)

    q podria hacer?
     
  18. WebTech

    WebTech Súper Moderador Miembro del Staff Moderador CH

    frankxd,

    Tienes que tener el paquete de desarrollo instalado (generalmente se llama php-devel si lo instalas por RPM), de lo contrario no podrás usar phpize, escribe:

    CODE, HTML o PHP Insertado:
    rpm -q php-devel
    Fíjate si en esa salida aparece el paquete que te mencioné, si no aparece, tendrás que instalarlo.

    Saludos,
     


Alojamiento web, Hosting Reseller, Servidores Dedicados - All in Hosting


    
    
    
    
Blog · Sitios amigos: GuiaHosting · Unidominios · Interalta · Sobre Devandhost · Anna Telecom